Compliance dashboard not loading in Manager workspace

Incident Report for Juniper Square

Resolved

We deployed a fix and the Compliance dashboard is now working. Other areas of Manager workspace and the Investor Portal were unaffected. A post-incident review is underway.
Posted Jul 28, 2026 - 16:04 PDT

Investigating

We're investigating an issue where the Compliance dashboard in Manager workspace is failing to load for some users. This is the view GPs use for real-time visibility into AML/KYC status across investor positions. Other areas of Manager workspace and the Investor Portal are working normally. Our engineering team is actively investigating and we'll share an update shortly.
Posted Jul 28, 2026 - 15:12 PDT