Email delivery from Juniper Square affected

Incident Report for Juniper Square

Resolved

We’ve seen that email delivery has returned to normal. The message backlog is nearly cleared, and all email types are now processing and sending as expected.

Our engineering team is continuing to investigate the root cause to ensure ongoing stability. We don’t expect any further delays at this time.
Posted Feb 06, 2026 - 16:34 PST

Identified

We've identified the cause of the email delivery delays and are monitoring the system as the backlog clears. Emails already queued are being processed and sent out now.

You may experience delays with all email types, including user-generated messages and system notifications. We're tracking the recovery as the remaining messages are processed and will provide an update once delivery times have stabilized.
Posted Feb 06, 2026 - 15:52 PST

Investigating

We're investigating an issue that affects email delivery from Juniper Square. Our engineering team is working to identify the cause and will provide an update as soon as we have more information. Other platform features remain fully operational.
Posted Feb 06, 2026 - 15:23 PST