System performance and errors

Incident Report for Juniper Square

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 09:35 PDT

Investigating

We're investigating slow loading and errors affecting manager workspaces and investor portals. We've identified a recent update as the likely cause and are working to restore performance. We will update again within the next hour.
Posted Apr 28, 2026 - 09:20 PDT