Intermittent connectivity issues

Incident Report for Juniper Square

Resolved

We’ve successfully deployed a fix for the underlying update that caused the recent service disruption. All systems are continuing to operate normally. We’ll continue to monitor performance to ensure a smooth experience.
Posted Mar 11, 2026 - 14:51 PDT

Monitoring

Some users may have experienced brief, periodic connection timeouts while using Juniper Square.
We've identified the cause of these interruptions and the platform is currently stable and fully operational. Our engineering team is now working on a permanent resolution to ensure this doesn't recur.
Posted Mar 11, 2026 - 12:00 PDT